summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Trading/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Trading/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Trading/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/TAO/orbsvcs/tests/Trading/Makefile.am b/TAO/orbsvcs/tests/Trading/Makefile.am
index ef94122afda..4f692d0fb2a 100644
--- a/TAO/orbsvcs/tests/Trading/Makefile.am
+++ b/TAO/orbsvcs/tests/Trading/Makefile.am
@@ -28,7 +28,10 @@ BUILT_SOURCES = \
TTestC.inl \
TTestS.cpp \
TTestS.h \
- TTestS.inl
+ TTestS.inl \
+ TTestS_T.cpp \
+ TTestS_T.h \
+ TTestS_T.inl
CLEANFILES = \
TTest-stamp \
@@ -37,12 +40,15 @@ CLEANFILES = \
TTestC.inl \
TTestS.cpp \
TTestS.h \
- TTestS.inl
+ TTestS.inl \
+ TTestS_T.cpp \
+ TTestS_T.h \
+ TTestS_T.inl
-TTestC.cpp TTestC.h TTestC.inl TTestS.cpp TTestS.h TTestS.inl: TTest-stamp
+TTestC.cpp TTestC.h TTestC.inl TTestS.cpp TTestS.h TTestS.inl TTestS_T.cpp TTestS_T.h TTestS_T.inl: TTest-stamp
TTest-stamp: $(srcdir)/TTest.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -I..\..\.. -I..\..\..\orbsvcs -Wb,export_macro=TAO_TTest_Export -Wb,export_include=ttest_export.h $(srcdir)/TTest.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT -I..\..\.. -I..\..\..\orbsvcs -Wb,export_macro=TAO_TTest_Export -Wb,export_include=ttest_export.h $(srcdir)/TTest.idl
@touch $@
noinst_LTLIBRARIES = libTTest.la
@@ -76,6 +82,9 @@ noinst_HEADERS = \
TTestC.inl \
TTestS.h \
TTestS.inl \
+ TTestS_T.cpp \
+ TTestS_T.h \
+ TTestS_T.inl \
ttest_export.h
endif BUILD_EXCEPTIONS