summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am')
-rw-r--r--TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am b/TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am
index 0254eb4a88a..1da3c7e2ddc 100644
--- a/TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am
+++ b/TAO/performance-tests/Cubit/TAO/MT_Cubit/Makefile.am
@@ -21,6 +21,7 @@ noinst_PROGRAMS =
## Makefile.MT_Cubit_IDL.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
BUILT_SOURCES = \
cubitC.cpp \
@@ -49,6 +50,7 @@ cubit-stamp: $(srcdir)/cubit.idl $(TAO_IDL_DEP)
noinst_HEADERS = \
cubit.idl
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.MT_Cubit_Client.am
@@ -98,6 +100,7 @@ endif BUILD_EXCEPTIONS
## Makefile.MT_Cubit_Server.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -131,6 +134,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.