summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Latency/AMI/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Latency/AMI/Makefile.am')
-rw-r--r--TAO/performance-tests/Latency/AMI/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/TAO/performance-tests/Latency/AMI/Makefile.am b/TAO/performance-tests/Latency/AMI/Makefile.am
index 191481ab92c..9cc174f9ad0 100644
--- a/TAO/performance-tests/Latency/AMI/Makefile.am
+++ b/TAO/performance-tests/Latency/AMI/Makefile.am
@@ -60,6 +60,7 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -87,6 +88,7 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI
@@ -96,6 +98,7 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -125,6 +128,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI