summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Latency/DII/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Latency/DII/Makefile.am')
-rw-r--r--TAO/performance-tests/Latency/DII/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/TAO/performance-tests/Latency/DII/Makefile.am b/TAO/performance-tests/Latency/DII/Makefile.am
index 9b42af13b86..e73d3183a18 100644
--- a/TAO/performance-tests/Latency/DII/Makefile.am
+++ b/TAO/performance-tests/Latency/DII/Makefile.am
@@ -21,6 +21,7 @@ noinst_PROGRAMS =
## Makefile.DII_Latency_Idl.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
BUILT_SOURCES = \
TestC.cpp \
@@ -49,6 +50,7 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
noinst_HEADERS = \
Test.idl
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.DII_Latency_Client.am
@@ -89,6 +91,7 @@ endif BUILD_CORBA_MESSAGING
## Makefile.DII_Latency_Server.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -112,6 +115,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.