summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Latency/Deferred/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Latency/Deferred/Makefile.am')
-rw-r--r--TAO/performance-tests/Latency/Deferred/Makefile.am19
1 files changed, 12 insertions, 7 deletions
diff --git a/TAO/performance-tests/Latency/Deferred/Makefile.am b/TAO/performance-tests/Latency/Deferred/Makefile.am
index 68cec77b8ae..7413be425b8 100644
--- a/TAO/performance-tests/Latency/Deferred/Makefile.am
+++ b/TAO/performance-tests/Latency/Deferred/Makefile.am
@@ -13,14 +13,15 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
## Makefile.Deferred_Latency_Idl.am
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
BUILT_SOURCES = \
TestC.cpp \
@@ -45,16 +46,18 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
@touch $@
+
noinst_HEADERS = \
Test.idl
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
## Makefile.Deferred_Latency_Client.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -81,13 +84,14 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Deferred_Latency_Server.am
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -111,7 +115,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
## Clean up template repositories, etc.
clean-local: