summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am')
-rw-r--r--TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am b/TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am
index 513b93fdaa6..2512eb329b1 100644
--- a/TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am
+++ b/TAO/performance-tests/RTCorba/Thread_Pool/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -43,14 +43,15 @@ test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@
+
noinst_HEADERS = \
test.idl
## Makefile.Thread_Pool_RTCorba_Client.am
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -72,14 +73,14 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif !BUILD_ACE_FOR_TAO
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
## Makefile.Thread_Pool_RTCorba_Server.am
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -104,8 +105,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.
clean-local: