summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am')
-rw-r--r--TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am b/TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am
index fe523d61a7f..b91afb9c247 100644
--- a/TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am
+++ b/TAO/performance-tests/Sequence_Latency/Thread_Pool/Makefile.am
@@ -21,6 +21,7 @@ noinst_PROGRAMS =
## Makefile.Thread_Pool_Sequence_Idl.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
BUILT_SOURCES = \
TestC.cpp \
@@ -49,11 +50,13 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
noinst_HEADERS = \
Test.idl
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.Thread_Pool_Sequence_Client.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -75,11 +78,13 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.Thread_Pool_Sequence_Server.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -105,6 +110,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.