summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Throughput/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Throughput/Makefile.am')
-rw-r--r--TAO/performance-tests/Throughput/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/TAO/performance-tests/Throughput/Makefile.am b/TAO/performance-tests/Throughput/Makefile.am
index 8c1b7d7a447..eaaf48bf5bd 100644
--- a/TAO/performance-tests/Throughput/Makefile.am
+++ b/TAO/performance-tests/Throughput/Makefile.am
@@ -50,6 +50,7 @@ noinst_HEADERS = \
## Makefile.Throughput_Client.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -71,11 +72,13 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.Throughput_Server.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -101,6 +104,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.