summaryrefslogtreecommitdiff
path: root/TAO/tests/AMI_Timeouts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/AMI_Timeouts/Makefile.am')
-rw-r--r--TAO/tests/AMI_Timeouts/Makefile.am137
1 files changed, 0 insertions, 137 deletions
diff --git a/TAO/tests/AMI_Timeouts/Makefile.am b/TAO/tests/AMI_Timeouts/Makefile.am
deleted file mode 100644
index 8695c412368..00000000000
--- a/TAO/tests/AMI_Timeouts/Makefile.am
+++ /dev/null
@@ -1,137 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
-TAO_ROOT = $(top_srcdir)
-
-noinst_PROGRAMS =
-
-## Makefile.AMI_Timeouts_Idl.am
-
-if BUILD_AMI
-if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
-
-BUILT_SOURCES = \
- timeoutC.cpp \
- timeoutC.h \
- timeoutC.inl \
- timeoutS.cpp \
- timeoutS.h \
- timeoutS.inl
-
-CLEANFILES = \
- timeout-stamp \
- timeoutC.cpp \
- timeoutC.h \
- timeoutC.inl \
- timeoutS.cpp \
- timeoutS.h \
- timeoutS.inl
-
-timeoutC.cpp timeoutC.h timeoutC.inl timeoutS.cpp timeoutS.h timeoutS.inl: timeout-stamp
-
-timeout-stamp: $(srcdir)/timeout.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -GC $(srcdir)/timeout.idl
- @touch $@
-
-noinst_HEADERS = \
- timeout.idl
-
-endif BUILD_EXCEPTIONS
-endif BUILD_CORBA_MESSAGING
-endif BUILD_AMI
-
-## Makefile.AMI_Timeouts_Server.am
-
-if BUILD_AMI
-if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += server
-
-server_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-server_SOURCES = \
- server.cpp \
- timeoutC.cpp \
- timeoutS.cpp \
- timeout_client.cpp \
- timeout_i.cpp \
- timeout_client.h \
- timeout_i.h
-
-server_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-endif BUILD_CORBA_MESSAGING
-endif BUILD_AMI
-
-## Makefile.AMI_Timeouts_Client.am
-
-if BUILD_AMI
-if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client
-
-client_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-client_SOURCES = \
- client.cpp \
- timeoutC.cpp \
- timeoutS.cpp \
- timeout_client.cpp \
- timeout_i.cpp \
- timeout_client.h \
- timeout_i.h
-
-client_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-endif BUILD_CORBA_MESSAGING
-endif BUILD_AMI
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB