summaryrefslogtreecommitdiff
path: root/TAO/tests/Cache_Growth_Test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Cache_Growth_Test/Makefile.am')
-rw-r--r--TAO/tests/Cache_Growth_Test/Makefile.am52
1 files changed, 14 insertions, 38 deletions
diff --git a/TAO/tests/Cache_Growth_Test/Makefile.am b/TAO/tests/Cache_Growth_Test/Makefile.am
index 37e5cd6c5fa..d7a28116f17 100644
--- a/TAO/tests/Cache_Growth_Test/Makefile.am
+++ b/TAO/tests/Cache_Growth_Test/Makefile.am
@@ -17,14 +17,10 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.Cache_Growth_Test_Server.am
-
-if BUILD_EXCEPTIONS
+## Makefile.Cache_Growth_Test_Idl.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
TestC.cpp \
TestC.h \
TestC.inl \
@@ -32,7 +28,7 @@ BUILT_SOURCES += \
TestS.h \
TestS.inl
-CLEANFILES += \
+CLEANFILES = \
Test-stamp \
TestC.cpp \
TestC.h \
@@ -44,9 +40,17 @@ CLEANFILES += \
TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Test.idl
@touch $@
+
+noinst_HEADERS = \
+ Test.idl
+
+## Makefile.Cache_Growth_Test_Server.am
+
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -60,11 +64,7 @@ server_SOURCES = \
TestC.cpp \
TestS.cpp \
server.cpp \
- Hello.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Hello.h
server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
@@ -78,27 +78,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
-
-CLEANFILES += \
- Test-stamp \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
-
-TestC.cpp TestC.h TestC.inl TestS.h TestS.inl: Test-stamp
-
-Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
- @touch $@
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -110,10 +89,7 @@ client_CPPFLAGS = \
client_SOURCES = \
TestC.cpp \
client.cpp \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Hello.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \