summaryrefslogtreecommitdiff
path: root/TAO/tests/Client_Leaks/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Client_Leaks/Makefile.am')
-rw-r--r--TAO/tests/Client_Leaks/Makefile.am82
1 files changed, 15 insertions, 67 deletions
diff --git a/TAO/tests/Client_Leaks/Makefile.am b/TAO/tests/Client_Leaks/Makefile.am
index b268cbe8299..db289894063 100644
--- a/TAO/tests/Client_Leaks/Makefile.am
+++ b/TAO/tests/Client_Leaks/Makefile.am
@@ -17,14 +17,10 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.Client_Leaks_Server.am
-
-if BUILD_EXCEPTIONS
+## Makefile.Client_Leaks_Idl.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
TestC.cpp \
TestC.h \
TestC.inl \
@@ -32,7 +28,7 @@ BUILT_SOURCES += \
TestS.h \
TestS.inl
-CLEANFILES += \
+CLEANFILES = \
Test-stamp \
TestC.cpp \
TestC.h \
@@ -44,9 +40,17 @@ CLEANFILES += \
TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Test.idl
@touch $@
+
+noinst_HEADERS = \
+ Test.idl
+
+## Makefile.Client_Leaks_Server.am
+
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -64,11 +68,7 @@ server_SOURCES = \
server.cpp \
Process_Factory.h \
Server_Task.h \
- Startup_Callback.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Startup_Callback.h
server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
@@ -82,27 +82,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
-
-CLEANFILES += \
- Test-stamp \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
-
-TestC.cpp TestC.h TestC.inl TestS.h TestS.inl: Test-stamp
-
-Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
- @touch $@
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -115,11 +94,7 @@ client_SOURCES = \
Client_Task.cpp \
TestC.cpp \
client.cpp \
- Client_Task.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Client_Task.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
@@ -132,29 +107,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.cpp \
- TestS.h \
- TestS.inl
-
-CLEANFILES += \
- Test-stamp \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.cpp \
- TestS.h \
- TestS.inl
-
-TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
-
-Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
- @touch $@
-
noinst_PROGRAMS += child
child_CPPFLAGS = \
@@ -168,11 +120,7 @@ child_SOURCES = \
TestC.cpp \
TestS.cpp \
child.cpp \
- Process.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Process.h
child_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \