summaryrefslogtreecommitdiff
path: root/TAO/tests/Faults/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Faults/Makefile.am')
-rw-r--r--TAO/tests/Faults/Makefile.am156
1 files changed, 36 insertions, 120 deletions
diff --git a/TAO/tests/Faults/Makefile.am b/TAO/tests/Faults/Makefile.am
index e69eb2af040..0af16538933 100644
--- a/TAO/tests/Faults/Makefile.am
+++ b/TAO/tests/Faults/Makefile.am
@@ -17,14 +17,10 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.Faults_Server.am
-
-if BUILD_EXCEPTIONS
+## Makefile.Faults_Idl.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
testC.cpp \
testC.h \
testC.inl \
@@ -32,7 +28,7 @@ BUILT_SOURCES += \
testS.h \
testS.inl
-CLEANFILES += \
+CLEANFILES = \
test-stamp \
testC.cpp \
testC.h \
@@ -44,9 +40,41 @@ CLEANFILES += \
testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ pingC.cpp \
+ pingC.h \
+ pingC.inl \
+ pingS.cpp \
+ pingS.h \
+ pingS.inl
+
+CLEANFILES += \
+ ping-stamp \
+ pingC.cpp \
+ pingC.h \
+ pingC.inl \
+ pingS.cpp \
+ pingS.h \
+ pingS.inl
+
+pingC.cpp pingC.h pingC.inl pingS.cpp pingS.h pingS.inl: ping-stamp
+
+ping-stamp: $(srcdir)/ping.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/ping.idl
@touch $@
+
+noinst_HEADERS = \
+ ping.idl \
+ test.idl
+
+## Makefile.Faults_Server.am
+
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -60,10 +88,6 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
test_i.h \
test_i.inl
@@ -79,29 +103,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
- @touch $@
-
noinst_PROGRAMS += middle
middle_CPPFLAGS = \
@@ -115,10 +116,6 @@ middle_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
test_i.h \
test_i.inl
@@ -134,29 +131,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
- @touch $@
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -170,10 +144,6 @@ client_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
test_i.h \
test_i.inl
@@ -189,29 +159,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- pingC.cpp \
- pingC.h \
- pingC.inl \
- pingS.cpp \
- pingS.h \
- pingS.inl
-
-CLEANFILES += \
- ping-stamp \
- pingC.cpp \
- pingC.h \
- pingC.inl \
- pingS.cpp \
- pingS.h \
- pingS.inl
-
-pingC.cpp pingC.h pingC.inl pingS.cpp pingS.h pingS.inl: ping-stamp
-
-ping-stamp: $(srcdir)/ping.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/ping.idl
- @touch $@
-
noinst_PROGRAMS += ping
ping_CPPFLAGS = \
@@ -225,10 +172,6 @@ ping_SOURCES = \
pingC.cpp \
pingS.cpp \
ping_i.cpp \
- pingC.h \
- pingC.inl \
- pingS.h \
- pingS.inl \
ping_i.h \
ping_i.inl
@@ -244,29 +187,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- pingC.cpp \
- pingC.h \
- pingC.inl \
- pingS.cpp \
- pingS.h \
- pingS.inl
-
-CLEANFILES += \
- ping-stamp \
- pingC.cpp \
- pingC.h \
- pingC.inl \
- pingS.cpp \
- pingS.h \
- pingS.inl
-
-pingC.cpp pingC.h pingC.inl pingS.cpp pingS.h pingS.inl: ping-stamp
-
-ping-stamp: $(srcdir)/ping.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/ping.idl
- @touch $@
-
noinst_PROGRAMS += pong
pong_CPPFLAGS = \
@@ -280,10 +200,6 @@ pong_SOURCES = \
pingS.cpp \
ping_i.cpp \
pong.cpp \
- pingC.h \
- pingC.inl \
- pingS.h \
- pingS.inl \
ping_i.h \
ping_i.inl