summaryrefslogtreecommitdiff
path: root/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/IOR_Endpoint_Hostnames/Makefile.am')
-rw-r--r--TAO/tests/IOR_Endpoint_Hostnames/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am b/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
index dff8bc9b49b..0b5223e3059 100644
--- a/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
+++ b/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
@@ -16,7 +16,6 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
## Makefile.generate_ior.am
@@ -42,10 +41,10 @@ CLEANFILES = \
bogusC.cpp bogusC.h bogusC.inl bogusS.cpp bogusS.h bogusS.inl: bogus-stamp
bogus-stamp: $(srcdir)/bogus.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/bogus.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/bogus.idl
@touch $@
-noinst_PROGRAMS += generate_ior
+noinst_PROGRAMS = generate_ior
generate_ior_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -74,18 +73,17 @@ endif BUILD_EXCEPTIONS
## Makefile.list_interfaces.am
-noinst_PROGRAMS += list_interfaces
+noinst_LTLIBRARIES = liblist_interfaces.la
-list_interfaces_CPPFLAGS = \
+liblist_interfaces_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR)
-list_interfaces_SOURCES = \
- list_interfaces.cpp \
- bogus_i.h
+liblist_interfaces_la_SOURCES = \
+ list_interfaces.cpp
-list_interfaces_LDADD = \
- $(ACE_BUILDDIR)/ace/libACE.la
+noinst_HEADERS = \
+ bogus_i.h
## Clean up template repositories, etc.
clean-local: