summaryrefslogtreecommitdiff
path: root/TAO/tests/OBV/TC_Alignment/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/OBV/TC_Alignment/Makefile.am')
-rw-r--r--TAO/tests/OBV/TC_Alignment/Makefile.am50
1 files changed, 13 insertions, 37 deletions
diff --git a/TAO/tests/OBV/TC_Alignment/Makefile.am b/TAO/tests/OBV/TC_Alignment/Makefile.am
index bca0965af2b..f8c18499f3e 100644
--- a/TAO/tests/OBV/TC_Alignment/Makefile.am
+++ b/TAO/tests/OBV/TC_Alignment/Makefile.am
@@ -17,14 +17,10 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.OBV_TC_Alignment_Server.am
-
-if BUILD_EXCEPTIONS
+## Makefile.OBV_TC_Alignment_Idl.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
testC.cpp \
testC.h \
testC.inl \
@@ -32,7 +28,7 @@ BUILT_SOURCES += \
testS.h \
testS.inl
-CLEANFILES += \
+CLEANFILES = \
test-stamp \
testC.cpp \
testC.h \
@@ -44,9 +40,17 @@ CLEANFILES += \
testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@
+
+noinst_HEADERS = \
+ test.idl
+
+## Makefile.OBV_TC_Alignment_Server.am
+
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -60,10 +64,6 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
test_i.h
server_LDADD = \
@@ -79,27 +79,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
- @touch $@
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -111,10 +90,7 @@ client_CPPFLAGS = \
client_SOURCES = \
client.cpp \
testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
+ test_i.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \