summaryrefslogtreecommitdiff
path: root/ace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ace/Makefile.am')
-rw-r--r--ace/Makefile.am35
1 files changed, 3 insertions, 32 deletions
diff --git a/ace/Makefile.am b/ace/Makefile.am
index 10b42bdba57..cd4ad3999d6 100644
--- a/ace/Makefile.am
+++ b/ace/Makefile.am
@@ -138,11 +138,6 @@ libACE_OS_la_SOURCES = \
OS_Memory.cpp \
OS_String.cpp \
OS_TLI.cpp \
- Thread_Hook.cpp \
- Base_Thread_Adapter.cpp \
- OS_Thread_Adapter.cpp \
- Thread_Exit.cpp \
- Thread_Control.cpp \
Sched_Params.cpp
libACE_Utils_la_SOURCES = \
@@ -193,7 +188,6 @@ libACE_Threads_la_SOURCES = \
Synch.cpp \
Synch_Options.cpp \
Thread.cpp \
- Thread_Adapter.cpp \
Thread_Manager.cpp \
Token.cpp
@@ -208,7 +202,6 @@ libACE_Demux_la_SOURCES = \
Reactor.cpp \
Select_Reactor.cpp \
Select_Reactor_Base.cpp \
- SUN_Proactor.cpp \
TP_Reactor.cpp \
TkReactor.cpp \
WFMO_Reactor.cpp \
@@ -236,6 +229,7 @@ libACE_Sockets_la_SOURCES = \
SOCK_Dgram.cpp \
SOCK_Dgram_Bcast.cpp \
SOCK_Dgram_Mcast.cpp \
+ SOCK_Dgram_Mcast_QoS.cpp \
SOCK_IO.cpp \
SOCK_Stream.cpp
@@ -340,11 +334,9 @@ libACE_Other_la_SOURCES = \
Naming_Context.cpp \
Registry_Name_Space.cpp \
Remote_Name_Space.cpp \
- SOCK_Dgram_Mcast_QoS.cpp \
QoS_Session_Impl.cpp \
QoS_Session_Factory.cpp \
- QoS_Manager.cpp \
- QoS_Decorator.cpp
+ QoS_Manager.cpp
libACE_la_SOURCES = \
$(libACE_OS_la_SOURCES) \
@@ -433,7 +425,6 @@ TEMPLATE_FILES = \
Future.cpp \
Future_Set.cpp \
Hash_Map_Manager_T.cpp \
- Hash_Map_With_Allocator_T.cpp \
Hash_Cache_Map_Manager_T.cpp \
IOStream_T.cpp \
LOCK_SOCK_Acceptor.cpp \
@@ -563,7 +554,6 @@ HEADER_FILES = \
Log_Msg.h \
Log_Priority.h \
Log_Record.h \
- Logging_Strategy.h \
MEM_Acceptor.h \
MEM_Addr.h \
MEM_Connector.h \
@@ -595,11 +585,6 @@ HEADER_FILES = \
Name_Space.h \
Naming_Context.h \
OS.h \
- OS_Dirent.h \
- OS_Export.h \
- OS_Memory.h \
- OS_String.h \
- OS_TLI.h \
Object_Manager.h \
Obstack.h \
POSIX_Asynch_IO.h \
@@ -614,7 +599,6 @@ HEADER_FILES = \
Process.h \
Process_Manager.h \
Profile_Timer.h \
- QoS_Decorator.h \
QoS_Manager.h \
QoS_Session.h \
QoS_Session_Factory.h \
@@ -644,7 +628,6 @@ HEADER_FILES = \
SPIPE_Connector.h \
SPIPE_Stream.h \
SString.h \
- SUN_Proactor.h \
SV_Message.h \
SV_Message_Queue.h \
SV_Semaphore_Complex.h \
@@ -686,10 +669,6 @@ HEADER_FILES = \
Task.h \
Task_T.h \
Thread.h \
- Thread_Adapter.h \
- Thread_Control.h \
- Thread_Exit.h \
- Thread_Hook.h \
Thread_Manager.h \
Time_Request_Reply.h \
Time_Value.h \
@@ -726,7 +705,6 @@ HEADER_FILES = \
WIN32_Proactor.h \
XTI_ATM_Mcast.h \
XtReactor.h \
- ace_wchar.h \
config.h \
config-all.h \
iosfwd.h \
@@ -858,7 +836,6 @@ INLINE_FILES = \
SPIPE_Connector.i \
SPIPE_Stream.i \
SString.i \
- SUN_Proactor.i \
SV_Message.i \
SV_Message_Queue.i \
SV_Semaphore_Complex.i \
@@ -906,13 +883,7 @@ INLINE_FILES = \
UPIPE_Connector.i \
UPIPE_Stream.i \
WFMO_Reactor.i \
- XTI_ATM_Mcast.i \
- OS_Dirent.inl \
- OS_Memory.inl \
- OS_String.inl \
- OS_TLI.inl \
- Thread_Adapter.inl \
- Thread_Control.inl
+ XTI_ATM_Mcast.i
## It would be good to remove pkgincludedir. However, we want to install