summaryrefslogtreecommitdiff
path: root/netsvcs/clients/Logger/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netsvcs/clients/Logger/Makefile.am')
-rw-r--r--netsvcs/clients/Logger/Makefile.am53
1 files changed, 16 insertions, 37 deletions
diff --git a/netsvcs/clients/Logger/Makefile.am b/netsvcs/clients/Logger/Makefile.am
index 962adef1494..70449c5e220 100644
--- a/netsvcs/clients/Logger/Makefile.am
+++ b/netsvcs/clients/Logger/Makefile.am
@@ -1,45 +1,24 @@
-## Process this file with automake to create Makefile.in
+##----------------------------------------------------------------------------
+## $Id$
##
-## $Id$
+## Makefile for client logging applications
+##----------------------------------------------------------------------------
+
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Process this file with automake to create Makefile.in
##
-## MPC Command:
-## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -hierarchy -make_coexistence -exclude build,Kokyu
-
-ACE_BUILDDIR = $(top_builddir)
-
-## Makefile.direct_logging.am
-noinst_PROGRAMS = direct_logging
-
-direct_logging_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR)
-
-direct_logging_SOURCES = \
- direct_logging.cpp
-
-direct_logging_LDADD = \
- $(top_builddir)/netsvcs/lib/libnetsvcs.la $(top_builddir)/ace/libACE.la
-## Makefile.indirect_logging.am
-noinst_PROGRAMS += indirect_logging
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
-indirect_logging_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR)
+## LDFLAGS =
+## Libtool will automatically link against the "proper" library.
+## Do not change the "libACE.la." It is not a typographical error!
+LDADD = $(top_builddir)/ace/libACE.la
-indirect_logging_SOURCES = \
- indirect_logging.cpp
+noinst_PROGRAMS = \
+ direct_logging \
+ indirect_logging
-indirect_logging_LDADD = \
- $(top_builddir)/netsvcs/lib/libnetsvcs.la $(top_builddir)/ace/libACE.la
+direct_logging_SOURCES = direct_logging.cpp
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
- -rm -rf ptrepository SunWS_cache Templates.DB
+indirect_logging_SOURCES = indirect_logging.cpp