summaryrefslogtreecommitdiff
path: root/netsvcs/clients/Naming/Client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netsvcs/clients/Naming/Client/Makefile.am')
-rw-r--r--netsvcs/clients/Naming/Client/Makefile.am53
1 files changed, 17 insertions, 36 deletions
diff --git a/netsvcs/clients/Naming/Client/Makefile.am b/netsvcs/clients/Naming/Client/Makefile.am
index c1e6cfc66ac..95879536177 100644
--- a/netsvcs/clients/Naming/Client/Makefile.am
+++ b/netsvcs/clients/Naming/Client/Makefile.am
@@ -1,50 +1,31 @@
-## Process this file with automake to create Makefile.in
+##----------------------------------------------------------------------------
+## $Id$
##
-## $Id$
+## Makefile for the client programs that test the ACE network services
+##----------------------------------------------------------------------------
+
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Process this file with automake to create Makefile.in
##
-## MPC Command:
-## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -hierarchy -make_coexistence -exclude build,Kokyu
-
-ACE_BUILDDIR = $(top_builddir)
-
-## Makefile.Netsvsc_Client_Test_Lib.am
-noinst_LTLIBRARIES = libClient_Test.la
-
-libClient_Test_la_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR) \
- -DACE_CLIENT_TEST_BUILD_DLL
-libClient_Test_la_SOURCES = \
- Client_Test.cpp
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
-libClient_Test_la_LIBADD = \
- $(top_builddir)/ace/libACE.la
+noinst_LIBRARIES = libClient_Test.a
-noinst_HEADERS = \
- Client_Test.h
+libClient_Test_a_SOURCES = Client_Test.cpp Client_Test.h
-## Makefile.Netsvcs_Client_Test.am
-noinst_PROGRAMS = main
+noinst_PROGRAMS = \
+ main
-main_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR)
+main_SOURCES = main.cpp
+main_LDADD = libClient_Test.a \
+ $(top_builddir)/ace/libACE.la
-main_SOURCES = \
- main.cpp \
- Client_Test.h
+noinst_DATA = svc.conf svc2.conf
-main_LDADD = \
- libClient_Test.la $(top_builddir)/ace/libACE.la
+EXTRA_DIST = $(noinst_DATA)
## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
- -rm -rf ptrepository SunWS_cache Templates.DB
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations