summaryrefslogtreecommitdiff
path: root/netsvcs/clients/Naming/Dump_Restore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netsvcs/clients/Naming/Dump_Restore/Makefile.am')
-rw-r--r--netsvcs/clients/Naming/Dump_Restore/Makefile.am57
1 files changed, 17 insertions, 40 deletions
diff --git a/netsvcs/clients/Naming/Dump_Restore/Makefile.am b/netsvcs/clients/Naming/Dump_Restore/Makefile.am
index cc5dfd0c1c7..22a196c18fb 100644
--- a/netsvcs/clients/Naming/Dump_Restore/Makefile.am
+++ b/netsvcs/clients/Naming/Dump_Restore/Makefile.am
@@ -1,50 +1,27 @@
-## Process this file with automake to create Makefile.in
+##----------------------------------------------------------------------------
+## $Id$
##
-## $Id$
+## Makefile for the ACE Dump-Restore Name_Server utility
+##----------------------------------------------------------------------------
+
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Process this file with automake to create Makefile.in
##
-## MPC Command:
-## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -hierarchy -make_coexistence -exclude build,Kokyu
-
-ACE_BUILDDIR = $(top_builddir)
-
-## Makefile.Netsvcs_Dump_Restore_Lib.am
-noinst_LTLIBRARIES = libDump_Restore.la
-
-libDump_Restore_la_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR) \
- -DACE_BUILD_SVC_DLL
-
-libDump_Restore_la_SOURCES = \
- Dump_Restore.cpp
-
-libDump_Restore_la_LIBADD = \
- $(top_builddir)/ace/libACE.la
-noinst_HEADERS = \
- Dump_Restore.h
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
-## Makefile.Netsvcs_Dump_Restore.am
-noinst_PROGRAMS = main
+noinst_LIBRARIES = \
+ libDump_Restore.a
-main_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR)
+libDump_Restore_a_SOURCES = Dump_Restore.cpp Dump_Restore.h
-main_SOURCES = \
- main.cpp \
- Dump_Restore.h
+noinst_PROGRAMS = \
+ main
+main_SOURCES = main.cpp
main_LDADD = \
- libDump_Restore.la $(top_builddir)/ace/libACE.la
+ libDump_Restore.a \
+ $(top_builddir)/ace/libACE.la
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
- -rm -rf ptrepository SunWS_cache Templates.DB
+## ACE currently doesn't build this so we don't build it with automake either.
+EXTRA_DIST = createfile.cpp