summaryrefslogtreecommitdiff
path: root/netsvcs/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netsvcs/lib/Makefile.am')
-rw-r--r--netsvcs/lib/Makefile.am78
1 files changed, 40 insertions, 38 deletions
diff --git a/netsvcs/lib/Makefile.am b/netsvcs/lib/Makefile.am
index 7fd980d3c3b..a527f3ef54b 100644
--- a/netsvcs/lib/Makefile.am
+++ b/netsvcs/lib/Makefile.am
@@ -1,51 +1,53 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
+##---------------------------------------------------------------------------
+## $Id$
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Makefile for the server-side ACE network services
##
-## MPC Command:
-## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -hierarchy -make_coexistence -exclude build,Kokyu
+##---------------------------------------------------------------------------
-ACE_BUILDDIR = $(top_builddir)
+##
+## Process this file with automake to create Makefile.in
+##
-## Makefile.netsvcs.am
-noinst_LTLIBRARIES = libnetsvcs.la
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
-libnetsvcs_la_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR) \
- -DACE_NETSVCS_BUILD_DLL
+lib_LTLIBRARIES = libnetsvcs.la
libnetsvcs_la_SOURCES = \
- Base_Optimizer.cpp \
- Client_Logging_Handler.cpp \
- Log_Message_Receiver.cpp \
- Name_Handler.cpp \
- Server_Logging_Handler.cpp \
- TS_Clerk_Handler.cpp \
- TS_Server_Handler.cpp \
- Token_Handler.cpp
-
-libnetsvcs_la_LIBADD = \
- $(top_builddir)/ace/libACE.la
+ Base_Optimizer.cpp \
+ Client_Logging_Handler.cpp \
+ Log_Message_Receiver.cpp \
+ Name_Handler.cpp \
+ Server_Logging_Handler.cpp \
+ Server_Logging_Handler_T.cpp \
+ TS_Clerk_Handler.cpp \
+ TS_Server_Handler.cpp \
+ Token_Handler.cpp
+
+libnetsvcs_la_LDFLAGS = \
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
noinst_HEADERS = \
- Base_Optimizer.h \
- Client_Logging_Handler.h \
- Log_Message_Receiver.h \
- Name_Handler.h \
- Server_Logging_Handler.h \
- Server_Logging_Handler_T.h \
- TS_Clerk_Handler.h \
- TS_Server_Handler.h \
- Token_Handler.h \
- Server_Logging_Handler_T.cpp
+ Base_Optimizer.h \
+ Client_Logging_Handler.h \
+ Log_Message_Receiver.h \
+ Name_Handler.h \
+ Server_Logging_Handler.h \
+ Server_Logging_Handler_T.h \
+ TS_Clerk_Handler.h \
+ TS_Server_Handler.h \
+ Token_Handler.h
## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
- -rm -rf ptrepository SunWS_cache Templates.DB
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
+
+
+## What do we about the below? It was in the original libnetsvcs Makefile.
+## ifeq ($(SUPPRESS_DASH_G),1)
+## #### Build this target without -g on some platforms.
+## $(VDIR)Server_Logging_Handler.o $(VSHDIR)Server_Logging_Handler.$(SOEXT):
+## $(COMPILE-NO_DASH_G.cc) -o $@ $<
+## endif # SUPPRESS_DASH_G
+