summaryrefslogtreecommitdiff
path: root/netsvcs/servers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netsvcs/servers/Makefile.am')
-rw-r--r--netsvcs/servers/Makefile.am36
1 files changed, 12 insertions, 24 deletions
diff --git a/netsvcs/servers/Makefile.am b/netsvcs/servers/Makefile.am
index b1dbc676a98..6e1c58949a2 100644
--- a/netsvcs/servers/Makefile.am
+++ b/netsvcs/servers/Makefile.am
@@ -1,33 +1,21 @@
-## Process this file with automake to create Makefile.in
+##----------------------------------------------------------------------------
+## $Id$
##
-## $Id$
+## Makefile.am for the netsvcs server example
+##----------------------------------------------------------------------------
+
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Process this file with automake to create Makefile.in
##
-## MPC Command:
-## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -hierarchy -make_coexistence -exclude build,Kokyu
-ACE_ROOT = $(top_srcdir)
-ACE_BUILDDIR = $(top_builddir)
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -I$(top_srcdir)/netsvcs/lib
-## Makefile.Netsvcs_server.am
noinst_PROGRAMS = main
-main_CPPFLAGS = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(ACE_BUILDDIR) \
- -I$(ACE_ROOT)/netsvcs/lib
-
-main_SOURCES = \
- main.cpp
+main_SOURCES = main.cpp
+main_LDADD = $(top_builddir)/netsvcs/lib/libnetsvcs.la \
+ $(top_builddir)/ace/libACE.la
-main_LDADD = \
- $(top_builddir)/netsvcs/lib/libnetsvcs.la $(top_builddir)/ace/libACE.la
+noinst_DATA = svc.conf
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
- -rm -rf ptrepository SunWS_cache Templates.DB
+EXTRA_DIST = $(noinst_DATA)