summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBui Nguyen Quoc Thanh <thanh.buinguyenquoc@vn.bosch.com>2021-01-11 13:33:38 +0700
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-06-30 10:54:59 +0900
commit8fa28df721e7038450d6479de697d2cdf91055eb (patch)
tree959d7d1e599e80e43014cea3cda3cbd50536ebf2 /debian/rules
parent70bc426417b7aa29918642e4e8056c533306c931 (diff)
downloadDLT-daemon-8fa28df721e7038450d6479de697d2cdf91055eb.tar.gz
Debian packaging
First Debian release Signed-off-by: Bui Nguyen Quoc Thanh <thanh.buinguyenquoc@vn.bosch.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..993ce30
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE=1
+
+%:
+ dh $@ --buildsystem cmake --builddirectory=build
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -DWITH_SYSTEMD=ON -DWITH_SYSTEMD_JOURNAL=ON \
+ -DWITH_MAN=ON -DWITH_DLT_DBUS=ON \
+ -DWITH_DLT_KPI=ON -DWITH_DLT_ADAPTOR=ON \
+ -DWITH_DLT_SYSTEM=ON -DCMAKE_INSTALL_PREFIX=/opt/tooling/dlt \
+ -DCMAKE_INSTALL_SYSCONFDIR=/opt/tooling/dlt/etc
+
+override_dh_install:
+ sed -i 's/INSTALL_PREFIX_PATH/opt\/tooling\/dlt/g' debian/*.install; \
+ dh_install