summaryrefslogtreecommitdiff
path: root/src/dlt-qnx-system/CMakeLists.txt
diff options
context:
space:
mode:
authorNguyen Dinh Thi <Thi.NguyenDinh@vn.bosch.com>2018-11-29 16:30:32 +0100
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2020-07-08 16:01:00 +0900
commitc78d08d63f47ec2baa08c20f3068adbe8c3cc0ca (patch)
tree5485f250f358e3b875f9a33d4846fe40dbf9b47b /src/dlt-qnx-system/CMakeLists.txt
parent6b1781cb5ef5d6586dbe5c06bd973a0957c91813 (diff)
downloadDLT-daemon-c78d08d63f47ec2baa08c20f3068adbe8c3cc0ca.tar.gz
slog2 adapter on QNX
dlt-qnx-system can be used to send syslog on QNX to dlt-daemon using slog2 API. It was be built with setting cmake option WITH_DLT_QNX_SYSTEM to ON. Add markdown manual page for dlt-qnx-system Signed-off-by: Nguyen Dinh Thi (RBVH/ENG2) <Thi.NguyenDinh@vn.bosch.com> Signed-off-by: Le Hoang Ngoc Quynh <Quynh.LeHoangNgoc@vn.bosch.com> Signed-off-by: Sebastian Unger <sunger@de.adit-jv.com> Signed-off-by: Bui Nguyen Quoc Thanh <Thanh.BuiNguyenQuoc@vn.bosch.com> Signed-off-by: Saya Sugiura <ssugiura@jp.adit-jv.com> Signed-off-by: Felix Herrmann <fherrmann@de.adit-jv.com>
Diffstat (limited to 'src/dlt-qnx-system/CMakeLists.txt')
-rw-r--r--src/dlt-qnx-system/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/dlt-qnx-system/CMakeLists.txt b/src/dlt-qnx-system/CMakeLists.txt
new file mode 100644
index 0000000..9a9db46
--- /dev/null
+++ b/src/dlt-qnx-system/CMakeLists.txt
@@ -0,0 +1,33 @@
+#######
+# @licence make begin@
+# SPDX license identifier: MPL-2.0
+#
+# Copyright (C) 2018 Advanced Driver Information Technology.
+#
+# This file is part of GENIVI Project DLT - Diagnostic Log and Trace.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License (MPL), v. 2.0.
+# If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# For further information see http://www.genivi.org/.
+# @licence end@
+#######
+
+if(NOT WITH_DLT_CXX11_EXT)
+ message(FATAL_ERROR "DLT_QNX_SYSTEM needs the C++ features of dlt, please enable the WITH_DLT_CXX11_EXT option.")
+endif()
+
+set(dlt-qnx-system_SRCS dlt-qnx-system.c dlt-qnx-slogger2-adapter.cpp)
+add_executable(dlt-qnx-system ${dlt-qnx-system_SRCS})
+
+target_link_libraries(dlt-qnx-system dlt slog2parse json)
+
+install(TARGETS dlt-qnx-system
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+
+install(FILES dlt-qnx-system.conf dlt-slog2ctxt.json
+ DESTINATION ${CONFIGURATION_FILES_DIR}
+ COMPONENT base)