summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Probert <linus.probert@gmail.com>2023-04-19 11:28:50 +0200
committerGitHub <noreply@github.com>2023-04-19 11:28:50 +0200
commit5ca800c65fba4738dedf85058fef2eca3251fe18 (patch)
tree100b5175f09cc8a75d3d52b1051539665a571585 /tests/CMakeLists.txt
parenta87a6985b86dce769167a4cb87afcf29abc77fbe (diff)
downloadDLT-daemon-5ca800c65fba4738dedf85058fef2eca3251fe18.tar.gz
logstorage: Adds option to write logs in gzip format (#442)
* logstorage: Adds option to write logs in gzip format Adds functionality to allow storing offline logs in gzipped files instead of standard dlt files. * Ensure tests run safely with or without GZIP compression enabled * Enforce minimum version of zlib if enabling gzip compression
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index be0889c..579d730 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -64,7 +64,7 @@ endif()
foreach(target IN LISTS TARGET_LIST)
set(target_SRCS ${target})
add_executable(${target} ${target_SRCS} ${systemd_SRCS})
- target_link_libraries(${target} ${DLT_DAEMON_LIBRARIES})
+ target_link_libraries(${target} ${DLT_DAEMON_LIBRARIES} ${ZLIB_LIBRARY})
if(${target} STREQUAL "gtest_dlt_daemon_event_handler"
OR ${target} STREQUAL "gtest_dlt_shm"
OR ${target} STREQUAL "gtest_dlt_daemon_multiple_files_logging")