summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDoctorNoobingstoneIPresume <47064117+DoctorNoobingstoneIPresume@users.noreply.github.com>2021-11-15 07:51:54 +0200
committerGitHub <noreply@github.com>2021-11-15 14:51:54 +0900
commitaa1364fbdf8700a2c3d2176180f92fb9a4b44251 (patch)
treef5a31839cd90d05b1c3f54c1099ff0f3be1539f7 /tests/CMakeLists.txt
parent68fb45019d04b637d5a51fbda411599ccf779dad (diff)
downloadDLT-daemon-aa1364fbdf8700a2c3d2176180f92fb9a4b44251.tar.gz
Support for Cygwin toolchain. (#351)
Also tested with the latest version running on Windows XP (gcc-5.4.0) (http://www.crouchingtigerhiddenfruitbat.org/cygwin/timemachine.html). Signed-off-by: Adder <adder_2003@yahoo.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index a461891..b3a9339 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -15,7 +15,7 @@ else()
set(GTEST_LIBS ${GTEST_BOTH_LIBRARIES})
endif()
-if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+if("${CMAKE_SYSTEM_NAME}" MATCHES "Linux|CYGWIN")
set(LIBRARIES "")
else()
set(LIBRARIES socket)