summaryrefslogtreecommitdiff
path: root/src/console/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/console/CMakeLists.txt')
-rw-r--r--src/console/CMakeLists.txt17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/console/CMakeLists.txt b/src/console/CMakeLists.txt
index 521e464..b609405 100644
--- a/src/console/CMakeLists.txt
+++ b/src/console/CMakeLists.txt
@@ -17,11 +17,24 @@ set(dlt_control_common_SRCS ${CMAKE_CURRENT_SOURCE_DIR}/dlt-control-common.c)
add_library(dlt_control_common_lib STATIC ${dlt_control_common_SRCS})
target_link_libraries(dlt_control_common_lib dlt ${DLT_JSON_LIBRARY})
-set(TARGET_LIST dlt-convert dlt-receive)
+set(TARGET_LIST "")
+
+if (WITH_DLT_CONSOLE_RECEIVE)
+ list(APPEND TARGET_LIST dlt-receive)
+endif()
+
+if (WITH_DLT_CONSOLE_CONVERT)
+ list(APPEND TARGET_LIST dlt-convert)
+endif()
if(NOT WITH_DLT_CONSOLE_WO_CTRL)
add_subdirectory(logstorage)
- list(APPEND TARGET_LIST dlt-control dlt-passive-node-ctrl)
+ if (WITH_DLT_CONSOLE_CONTROL)
+ list(APPEND TARGET_LIST dlt-control)
+ endif()
+ if (WITH_DLT_CONSOLE_PASSIVE_NODE_CTRL)
+ list(APPEND TARGET_LIST dlt-passive-node-ctrl)
+ endif()
endif()
if(NOT WITH_DLT_CONSOLE_WO_SBTM)