summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-04-01 13:45:00 +0200
committerThomas Haller <thaller@redhat.com>2022-04-01 14:01:45 +0200
commit12299ee91e7950f3ee68057b0888fa34c02f1a29 (patch)
treef6484ae8319a3486bfae80b3142c786887a4491b /Makefile.am
parent49b0a92b5a48ab036656bd8a156e87481382dd71 (diff)
downloadNetworkManager-12299ee91e7950f3ee68057b0888fa34c02f1a29.tar.gz
build: drop "check-python-black" check from autotools
Previously, autotools would detect whether we have "black" in the path. And if so, it would check formatting during `make check`. That's problematic. When I run `./contrib/fedora/rpm/build_clean.sh -w test` in certain cases, it would pick up black, but then fail with Traceback (most recent call last): File "/usr/bin/black", line 5, in <module> from black import patched_main File "/usr/lib/python3.6/site-packages/black.py", line 42, in <module> from attr import dataclass, evolve, Factory ModuleNotFoundError: No module named 'attr' make[3]: *** [Makefile:21658: check-python-black] Error 1 That's an installation error of black, but still, during package build there is no need to check the formatting. We could export `NMTST_SKIP_PYTHON_BLACK=1` to prevent it, but it's still unnecessary. We check proper formatting in gitlab-ci. That is enough, it doesn't need to run during `make check`. In particular, because `black .` takes 1.5 seconds on my machine.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c7d5c934e3..784a346ad4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5679,12 +5679,6 @@ CLEANFILES += \
include Makefile.examples
-if WITH_PYTHON_BLACK
-check-python-black:
- test "$$NMTST_SKIP_PYTHON_BLACK" == 1 || $(BLACK) --check $(top_srcdir) $(top_srcdir)/examples/python/gi/nm-wg-set
-check_local += check-python-black
-endif
-
###############################################################################
check-tree: