summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-04-07 10:53:06 +0200
committerThomas Haller <thaller@redhat.com>2022-04-07 11:55:34 +0200
commit1234e5583a09a618b930241a12b8a1d580493568 (patch)
tree0c8796d4c354cb605e00f43ed2d263b8e00785b8 /Makefile.am
parent2dc7a3d9f9135959adf415405bdcb05a7387c1d4 (diff)
downloadNetworkManager-1234e5583a09a618b930241a12b8a1d580493568.tar.gz
build/autotools: avoid compiler warning generating "NM-1.0.gir"
We passed on the CFLAGS, but they also contain "-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_40 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40" which causes compiler warnings: GISCAN src/libnm-client-impl/NM-1.0.gir /data/src/NetworkManager/tmp-introspect_17ddrdb/NM-1.0.c: In function ‘dump_object_type’: /data/src/NetworkManager/tmp-introspect_17ddrdb/NM-1.0.c:251:13: warning: Not available before 2.70 251 | if (G_TYPE_IS_FINAL (type)) | ^~~~~~~~~~~~~~~~~ /data/src/NetworkManager/tmp-introspect_17ddrdb/NM-1.0.c: In function ‘dump_fundamental_type’: /data/src/NetworkManager/tmp-introspect_17ddrdb/NM-1.0.c:369:13: warning: Not available before 2.70 369 | if (G_TYPE_IS_FINAL (type)) | ^~~~~~~~~~~~~~~~~ Filter them out. See-also: https://gitlab.gnome.org/GNOME/gobject-introspection/-/merge_requests/331
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2cf4fcd286..60a171f528 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1898,7 +1898,7 @@ src_libnm_client_impl_NM_1_0_gir_INCLUDES = Gio-2.0
src_libnm_client_impl_NM_1_0_gir_PACKAGES = gio-2.0
src_libnm_client_impl_NM_1_0_gir_EXPORT_PACKAGES = libnm
src_libnm_client_impl_NM_1_0_gir_CFLAGS = \
- $(src_libnm_client_impl_libnm_la_CPPFLAGS) \
+ $(filter-out -DGLIB_VERSION_%, $(src_libnm_client_impl_libnm_la_CPPFLAGS)) \
-DNETWORKMANAGER_COMPILATION \
$(NULL)
src_libnm_client_impl_NM_1_0_gir_LIBS = src/libnm-client-impl/libnm.la