summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Zaborowski <andrew.zaborowski@intel.com>2021-11-06 06:16:00 +0100
committerThomas Haller <thaller@redhat.com>2022-01-21 11:16:14 +0100
commit51ef15709612677e59ccd5da58961fb673dfc77c (patch)
tree39d505a32f3ed61ed347411871caf624557df905 /Makefile.am
parent6bf080a7bb5cca2b5f03bcdd92a9dd33bb5d5257 (diff)
downloadNetworkManager-51ef15709612677e59ccd5da58961fb673dfc77c.tar.gz
iwd: Add basic P2P device class for IWD
Similarly as with wpa_supplicant, create NMDeviceIwdP2P objects for P2P devices based on data from IWD -- not in NMWifiFactory::create_device because that is only triggered for system netdevs and a P2P-Device virtual interface has no netdev. Unlike NMDeviceWifiP2P, NMDeviceIwdP2P's iface property is a unique string that likely doesn't match any system interface name -- in theory there doesn't need to be any related netdev on the system (such as an Infrastructure-mode interface) before a P2P-Device is added. [thaller@redhat.com: modified original patch]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 405577bd44..7a1616d50f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3935,6 +3935,8 @@ if WITH_IWD
src_core_devices_wifi_libnm_wifi_base_la_SOURCES += \
src/core/devices/wifi/nm-device-iwd.c \
src/core/devices/wifi/nm-device-iwd.h \
+ src/core/devices/wifi/nm-device-iwd-p2p.c \
+ src/core/devices/wifi/nm-device-iwd-p2p.h \
src/core/devices/wifi/nm-iwd-manager.c \
src/core/devices/wifi/nm-iwd-manager.h \
$(NULL)