summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-08-12 12:42:10 +0200
committerLubomir Rintel <lkundrak@v3.sk>2019-09-11 14:32:05 +0200
commit6e5385a4ebba29d17446239030a1ca1d0dd51898 (patch)
tree78ba8cb9f84bd9dad12612141f37a4519fa8ba21 /Makefile.am
parent6632c7709492182c795895c7d32ce2542a8d9e9a (diff)
downloadNetworkManager-6e5385a4ebba29d17446239030a1ca1d0dd51898.tar.gz
wwan/tests: test service-providers.xml parser
Just a handful of unit tests.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index aea13af505..7eb6a82674 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3367,11 +3367,35 @@ check-local-devices-wwan: src/devices/wwan/libnm-device-plugin-wwan.la src/devic
check_local += check-local-devices-wwan
+src_devices_wwan_tests_test_service_providers_SOURCES = \
+ src/devices/wwan/tests/test-service-providers.c \
+ src/devices/wwan/nm-service-providers.c \
+ src/devices/wwan/nm-service-providers.h \
+ $(NULL)
+
+src_devices_wwan_tests_test_service_providers_CPPFLAGS = \
+ $(src_cppflags_base_test) \
+ -I$(srcdir)/src/devices/wwan \
+ $(NULL)
+
+src_devices_wwan_tests_test_service_providers_LDFLAGS = \
+ $(SANITIZER_EXEC_LDFLAGS) \
+ $(NULL)
+
+src_devices_wwan_tests_test_service_providers_LDADD = \
+ src/libNetworkManagerTest.la \
+ $(GLIB_LIBS) \
+ $(NULL)
+
+check_programs += src/devices/wwan/tests/test-service-providers
+
endif
EXTRA_DIST += \
src/devices/wwan/libnm-wwan.ver \
- src/devices/wwan/meson.build
+ src/devices/wwan/meson.build \
+ src/devices/wwan/tests/test-service-providers.xml \
+ $(NULL)
###############################################################################
# src/devices/bluetooth