summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Hilliard <james.hilliard1@gmail.com>2021-12-02 18:34:10 -0700
committerThomas Haller <thaller@redhat.com>2022-01-04 06:41:37 +0100
commitedc37b3adf7d39057e7f06aa4ab736b38f7c8162 (patch)
tree25a05d73968070cd81ee162a4fc24b2ea018a360 /Makefile.am
parent7377df2f2d3910dc58c19263496fd3259f7732c7 (diff)
downloadNetworkManager-edc37b3adf7d39057e7f06aa4ab736b38f7c8162.tar.gz
build: allow configuring default for wifi.backend setting
Distributions may want to change the default wifi.backend, if for example they are building without wpa_supplicant support. https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/869 https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/1040
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98b1507c7c..6023b457c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -202,7 +202,8 @@ data_edit = sed \
-e 's|@NM_CONFIG_DEFAULT_LOGGING_BACKEND_TEXT[@]|$(NM_CONFIG_DEFAULT_LOGGING_BACKEND_TEXT)|g' \
-e 's|@NM_CONFIG_DEFAULT_LOGGING_AUDIT_TEXT[@]|$(NM_CONFIG_DEFAULT_LOGGING_AUDIT_TEXT)|g' \
-e 's|@NM_CONFIG_DEFAULT_MAIN_RC_MANAGER[@]|$(NM_CONFIG_DEFAULT_MAIN_RC_MANAGER)|g' \
- -e 's|@NM_CONFIG_DEFAULT_MAIN_DHCP[@]|$(NM_CONFIG_DEFAULT_MAIN_DHCP)|g'
+ -e 's|@NM_CONFIG_DEFAULT_MAIN_DHCP[@]|$(NM_CONFIG_DEFAULT_MAIN_DHCP)|g' \
+ -e 's|@NM_CONFIG_DEFAULT_WIFI_BACKEND_TEXT[@]|$(NM_CONFIG_DEFAULT_WIFI_BACKEND_TEXT)|g'
###############################################################################