summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWen Liang <liangwen12year@gmail.com>2021-06-06 21:15:12 -0400
committerThomas Haller <thaller@redhat.com>2021-07-19 17:41:52 +0200
commitf3404435a9fb24698dabdc80b52f52e9cc215730 (patch)
treee4b3b43e33c48bcd62974aafc25c91ced96bd69e /Makefile.am
parent09daf5dd9220f5715397725c9c77b2ec9f571895 (diff)
downloadNetworkManager-f3404435a9fb24698dabdc80b52f52e9cc215730.tar.gz
cloud-setup: configure secondary ip in Aliyun cloud
This is a tool for automatically configuring networking in Aliyun cloud environment. This add a provider implementation for Aliyun that when detected fetches the private ip addressess and the subnet prefix of IPv4 CIDR block. Once this information is fetched from the metadata server, it instructs NetworkManager to add private ip addressess and subnet prefix for each interface detected. It is inspired by SuSE's cloud-netconfig ([1], [2]) and Aliyun Instance Metadata [3]. [1] https://www.suse.com/c/multi-nic-cloud-netconfig-ec2-azure/ [2] https://github.com/SUSE-Enceladus/cloud-netconfig [3] https://www.alibabacloud.com/help/doc-detail/49122.htm It is also intended to work without configuration. The main point is that you boot an image with NetworkManager and nm-cloud-setup enabled, and it just works. https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/885 Signed-off-by: Wen Liang <liangwen12year@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 054a574ffa..0e72432039 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5137,6 +5137,8 @@ src_nm_cloud_setup_libnm_cloud_setup_core_a_SOURCES = \
src/nm-cloud-setup/nmcs-provider-gcp.h \
src/nm-cloud-setup/nmcs-provider-azure.c \
src/nm-cloud-setup/nmcs-provider-azure.h \
+ src/nm-cloud-setup/nmcs-provider-aliyun.c \
+ src/nm-cloud-setup/nmcs-provider-aliyun.h \
$(NULL)
src_nm_cloud_setup_libnm_cloud_setup_core_a_CPPFLAGS = \