summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2019-08-29 08:09:09 +0200
committerThomas Haller <thaller@redhat.com>2019-10-01 09:49:33 +0200
commit23b4dc5f77bb854e57ec2de07ed608f2a916a101 (patch)
tree629dbf767e9e15a821379767d3627d325ef362ef /data/meson.build
parent2172b885b4d0ee15ae572d26c2016b6a4f957e61 (diff)
downloadNetworkManager-23b4dc5f77bb854e57ec2de07ed608f2a916a101.tar.gz
meson: Rename variables related to pkg-config variables
Some variables belong to variables in their correspondent pkg-config file. These variables have been renamed to `dependency_variable` to reflect the dependency and variables from pkg-config files they are related to. Some of these has also been fixed to use paths relative to installation prefix.
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/data/meson.build b/data/meson.build
index b8e2e117ee..c317877070 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -13,7 +13,7 @@ configure_file(
configuration: data_conf,
)
-if install_systemd_unit_dir
+if install_systemdunitdir
services = [
'NetworkManager-dispatcher.service.in',
'NetworkManager.service.in',
@@ -29,7 +29,7 @@ if install_systemd_unit_dir
configure_file(
input: service,
output: '@BASENAME@',
- install_dir: systemd_system_unit_dir,
+ install_dir: systemd_systemdsystemunitdir,
configuration: data_conf,
)
endforeach
@@ -37,12 +37,12 @@ if install_systemd_unit_dir
if enable_ovs
install_data(
'NetworkManager-ovs.conf',
- install_dir: join_paths(systemd_system_unit_dir, 'NetworkManager.service.d'),
+ install_dir: join_paths(systemd_systemdsystemunitdir, 'NetworkManager.service.d'),
)
endif
endif
-if install_udev_dir
+if install_udevdir
data = files(
'84-nm-drivers.rules',
'85-nm-unmanaged.rules',
@@ -51,7 +51,7 @@ if install_udev_dir
install_data(
data,
- install_dir: join_paths(udev_dir, 'rules.d'),
+ install_dir: join_paths(udev_udevdir, 'rules.d'),
)
endif
@@ -70,6 +70,6 @@ if enable_polkit
output: '@BASENAME@',
command: intltool_xml_cmd,
install: true,
- install_dir: polkit_dir,
+ install_dir: polkit_gobject_policydir,
)
endif