summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-11-21 15:27:21 +0100
committerThomas Haller <thaller@redhat.com>2019-11-22 15:59:31 +0100
commit6d7270e222cce3edaf95c463bec9f3212f5e5c73 (patch)
treea705c53a638cb543ec89f1acfb862e7e958dca9d /data/meson.build
parent18c5ce50fbd40534cdd7d8e46277e89b7e7b5dd3 (diff)
downloadNetworkManager-6d7270e222cce3edaf95c463bec9f3212f5e5c73.tar.gz
build/meson: cleanup configuration_data() for paths
We don't need such data duplicated. The build setup should have only one configuration_data() for patching such values. Now we only have one global, immutable data_conf dictionary with configuration values. Note that none of the users of data_conf uses all entries, but as the entries are basically only dependent on the meson/configure option and valid for the entire project, this simplifies to handling.
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/data/meson.build b/data/meson.build
index c317877070..b572d27da2 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -1,11 +1,3 @@
-data_conf = configuration_data()
-data_conf.set('bindir', nm_bindir)
-data_conf.set('libexecdir', nm_libexecdir)
-data_conf.set('sbindir', nm_sbindir)
-data_conf.set('sysconfdir', nm_sysconfdir)
-data_conf.set('DISTRO_NETWORK_SERVICE', (enable_ifcfg_rh ? 'network.service' : ''))
-data_conf.set('NM_MODIFY_SYSTEM_POLICY', (enable_modify_system ? 'yes' : 'auth_admin_keep'))
-
configure_file(
input: 'server.conf.in',
output: '@BASENAME@',