summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2020-05-08 09:09:25 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2020-05-15 19:06:24 +0200
commitc8b5bf402d20077a73c15d55fc90c26e97119711 (patch)
tree846e71c73745e74f68e20a5bcb44e231ff460e85 /data/meson.build
parentfb0d59689c0d55c3592129c1161772550df79073 (diff)
downloadNetworkManager-c8b5bf402d20077a73c15d55fc90c26e97119711.tar.gz
build: install a firewalld zone for shared mode
Install a NM-specific firewalld zone to be used for interfaces that are used for connection sharing. The zone blocks all traffic to the local machine except some protocols (DHCP, DNS and ICMP) and allows all forwarded traffic.
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
index de08c91c62..b713a03c5a 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -67,3 +67,10 @@ if enable_polkit
install_dir: polkit_gobject_policydir,
)
endif
+
+if enable_firewalld_zone
+ install_data(
+ 'nm-shared.xml',
+ install_dir: join_paths(nm_prefix, 'lib', 'firewalld', 'zones')
+ )
+endif