summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-01-20 08:12:51 +0100
committerThomas Haller <thaller@redhat.com>2023-01-20 13:22:38 +0100
commit9ee42c0979d3889655a4394129c41133f7651b49 (patch)
tree6a1d3761ece8e29894e196ba4c979f2054dc2c4f /meson.build
parent93424dc2c26d432db4b4c7fa75298c7aa557789d (diff)
downloadNetworkManager-9ee42c0979d3889655a4394129c41133f7651b49.tar.gz
meson: increase "default_test_timeout" to 3 minutes
Obviously, it would be nice if our unit tests are fast. However, with valgrind and a busy machine, some of the tests can take a relatively long time. In particular those, that are marked as "slow" (if you want to skip them during development, do so via "NMTST_DEBUG=quick" environment, or "CFLAGS=-DNMTST_TEST_QUICK=TRUE", see "nm-test-utils.h"). Anyway. Our tests almost never hit the timeout, and if they do, the most likely reason is that something was just slower then expected, and the timeout is a bogus error. Timeouts only act as last fail safe. It more important to avoid a false (premature) timeout failure, than to minimize the wait time when the test really hangs. Because a real hang is a bug anyway, that we will discover and need to fix. Increase the default test timeout for meson tests to 3 minutes. Also, "test-route-linux" is known to take a long time. Increase that timeout even further.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d864ce8fd3..e6f0327d87 100644
--- a/meson.build
+++ b/meson.build
@@ -96,7 +96,7 @@ set_defines = [
['VERSION', nm_version],
]
-default_test_timeout = 90
+default_test_timeout = 180
foreach define: set_defines
config_h.set_quoted(define[0], define[1])