summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-11-03 10:18:04 +0100
committerThomas Haller <thaller@redhat.com>2022-11-07 08:50:07 +0100
commitf3682588b2db14a01c8631a293a06ad572874bfe (patch)
tree8e4a8c4c4cbacede9feb9a86189bef753420ec38 /meson.build
parentc884d4d347e90c77a71dffb48c521b551f1ec912 (diff)
downloadNetworkManager-f3682588b2db14a01c8631a293a06ad572874bfe.tar.gz
build/meson: sort compiler flags in "meson.build"
Also remove duplicates.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 3 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index ece045e5c5..57fd3959fb 100644
--- a/meson.build
+++ b/meson.build
@@ -184,11 +184,14 @@ common_flags += cc.get_supported_arguments([
'-Wmissing-declarations',
'-Wmissing-include-dirs',
'-Wmissing-prototypes',
+ '-Wparentheses-equality',
'-Wpointer-arith',
'-Wshadow',
'-Wshift-negative-value',
'-Wstrict-prototypes',
+ '-Wtypedef-redefinition',
'-Wundef',
+ '-Wunknown-attributes',
'-Wvla',
'-Wno-duplicate-decl-specifier',
'-Wno-format-truncation',
@@ -200,13 +203,6 @@ common_flags += cc.get_supported_arguments([
'-Wno-tautological-constant-out-of-range-compare',
'-Wno-unknown-pragmas',
'-Wno-unused-parameter',
- '-Wparentheses-equality',
- '-Wpointer-arith',
- '-Wshadow',
- '-Wstrict-prototypes',
- '-Wtypedef-redefinition',
- '-Wundef',
- '-Wunknown-attributes',
'-fno-strict-aliasing',
])