summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-08-11 17:33:12 +0200
committerThomas Haller <thaller@redhat.com>2016-08-12 09:38:51 +0200
commitf5a4a7e007bc1e27459c29fbae0588f61ca7e1f4 (patch)
tree1f7eca6499113af96b59c346266646105ca99254 /src/Makefile.am
parent4c849d148f330c17117b60137740a1e66ac1a237 (diff)
downloadNetworkManager-f5a4a7e007bc1e27459c29fbae0588f61ca7e1f4.tar.gz
systemd: hide "nm-sd-adapt.h" and expose required internal API in "nm-sd.h"
Users outside of src/systemd should not make use of internal API. Currently, "nm-dhcp-systemd.c" still makes use of internal systemd functions. Instead of letting "nm-dhcp-systemd.c" include internal headers, handpick the required defines to "nm-sd.h" and hide "nm-sd-adapt.h". "nm-sd-adapt.h" is now only used to compile internal systemd sources.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f5cf129897..039e2c0441 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -106,8 +106,8 @@ noinst_LTLIBRARIES = \
libsystemd_nm_la_SOURCES = \
systemd/nm-sd.c \
systemd/nm-sd.h \
- systemd/nm-sd-adapt.c \
- systemd/nm-sd-adapt.h \
+ systemd/sd-adapt/nm-sd-adapt.c \
+ systemd/sd-adapt/nm-sd-adapt.h \
systemd/sd-adapt/build.h \
systemd/sd-adapt/cgroup-util.h \
systemd/sd-adapt/condition.h \