summaryrefslogtreecommitdiff
path: root/vapi/meson.build
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-03-05 08:44:57 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-03-19 17:15:15 +0100
commit1de8383ad9fdfc8f552117e5d109bdfa7005634b (patch)
tree7b44996c8430157f2739b18148952859ea9e6b5f /vapi/meson.build
parent32e0bf1421263b07a1dde74d9281253cc1ea49ab (diff)
downloadNetworkManager-1de8383ad9fdfc8f552117e5d109bdfa7005634b.tar.gz
all: goodbye libnm-glib
This removes libnm-glib, libnm-glib-vpn, and libnm-util for good. The it has been replaced with libnm since NetworkManager 1.0, disabled by default since 1.12 and no up-to-date distributions ship it for years now. Removing the libraries allows us to: * Remove the horrible hacks that were in place to deal with accidental use of both the new and old library in a single process. * Relief the translators of maintenance burden of similar yet different strings. * Get rid of known bad code without chances of ever getting fixed (libnm-glib/nm-object.c and libnm-glib/nm-object-cache.c) * Generally lower the footprint of the releases and our workspace If there are some really really legacy users; they can just build libnm-glib and friends from the NetworkManager-1.16 distribution. The D-Bus API is stable and old libnm-glib will keep working forever. https://github.com/NetworkManager/NetworkManager/pull/308
Diffstat (limited to 'vapi/meson.build')
-rw-r--r--vapi/meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/vapi/meson.build b/vapi/meson.build
index addc8d7dd6..bc0984f22e 100644
--- a/vapi/meson.build
+++ b/vapi/meson.build
@@ -4,25 +4,3 @@ gnome.generate_vapi(
packages: 'gio-2.0',
install: true,
)
-
-if enable_libnm_glib
- packages = [
- 'dbus-glib-1',
- 'gio-2.0',
- ]
-
- libnm_util_vapi = gnome.generate_vapi(
- libnm_util_name,
- sources: libnm_util_gir[0],
- packages: packages,
- install: true,
- )
-
- gnome.generate_vapi(
- libnm_glib_name,
- sources: libnm_glib_gir[0],
- packages: packages + [libnm_util_vapi],
- gir_dirs: [join_paths(meson.current_build_dir(), '..', 'libnm-util')],
- install: true,
- )
-endif