summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 94b5152ef8..fcbc758cb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1101,26 +1101,22 @@ fi
AM_CONDITIONAL(INSTALL_PREGEN_MANPAGES, test "x${install_pregen_manpages}" = "xyes")
# check if we can build setting property documentation
-if test -n "$INTROSPECTION_MAKEFILE" -a "$enable_gtk_doc" = "yes"; then
+if test -n "$INTROSPECTION_MAKEFILE"; then
# If g-i is installed we know we have python, but we might not have pygobject
if ! python -c 'from gi.repository import GObject' >& /dev/null; then
- AC_MSG_ERROR(["--enable-gtk-doc --with-introspection" aims to build the settings documentation. This requires GObject introspection for python (pygobject)])
+ AC_MSG_ERROR(["--enable-introspection aims to build the settings documentation. This requires GObject introspection for python (pygobject)])
fi
- # gtk-doc depends on perl, but we can check for it anyway
AC_PATH_PROG(PERL, perl, no)
+ AC_PATH_PROG(XSLTPROC, xsltproc, no)
+ have_introspection=yes
build_setting_docs=yes
else
+ have_introspection=no
build_setting_docs=no
fi
-if test -n "$INTROSPECTION_MAKEFILE"; then
- have_introspection=yes
-else
- have_introspection=no
-fi
-
# check for pre-built setting docs
if test "$build_setting_docs" != "yes" \
-a -f man/nm-settings.xml \