summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e8910a6fdf..354db306e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,11 +550,20 @@ PKG_CHECK_MODULES(UUID, uuid)
PKG_CHECK_MODULES(JANSSON, [jansson], [have_jansson=yes], [have_jansson=no])
PKG_CHECK_MODULES(LIBTEAMDCTL, [libteamdctl >= 1.9], [have_teamdctl=yes],[have_teamdctl=no])
+if test "$have_jansson" = "yes" -a "$have_teamdctl" = "yes"; then
+ have_team_prereq=yes
+else
+ have_team_prereq=no
+fi
+
AC_ARG_ENABLE(teamdctl, AS_HELP_STRING([--enable-teamdctl], [enable Teamd control support]),
- [enable_teamdctl=${enableval}], [enable_teamdctl=${have_teamdctl}])
+ [enable_teamdctl=${enableval}], [enable_teamdctl=${have_team_prereq}])
if (test "${enable_teamdctl}" = "yes"); then
- if test x"$have_teamdctl" = x"no"; then
- AC_MSG_ERROR(Teamd control is required)
+ if test "$have_teamdctl" = "no"; then
+ AC_MSG_ERROR(Libteamdctl is required for team support)
+ fi
+ if test "$have_jansson" = "no"; then
+ AC_MSG_ERROR(Jansson is required for team support)
fi
# temporary bug workaround
LIBTEAMDCTL_CFLAGS=`echo $LIBTEAMDCTL_CFLAGS | sed -e 's:/teamdctl.h::'`