summaryrefslogtreecommitdiff
path: root/src/settings/plugins/ifcfg-rh/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/settings/plugins/ifcfg-rh/tests/Makefile.am')
-rw-r--r--src/settings/plugins/ifcfg-rh/tests/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/src/settings/plugins/ifcfg-rh/tests/Makefile.am b/src/settings/plugins/ifcfg-rh/tests/Makefile.am
index 4f9a8d177c..6e67fe008c 100644
--- a/src/settings/plugins/ifcfg-rh/tests/Makefile.am
+++ b/src/settings/plugins/ifcfg-rh/tests/Makefile.am
@@ -16,7 +16,11 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/settings \
-I$(top_srcdir)/src/wifi \
-I$(top_srcdir)/src/posix-signals \
- -I$(srcdir)/../
+ -I$(srcdir)/../ \
+ -DTEST_IFCFG_DIR=\"$(abs_srcdir)\" \
+ -DTEST_SCRATCH_DIR=\"$(abs_builddir)/\" \
+ -DSYSCONFDIR=\"nonexistent\" \
+ -DSBINDIR=\"nonexistent\"
AM_LDFLAGS = \
$(GLIB_LIBS) \
@@ -37,13 +41,6 @@ test_ifcfg_rh_SOURCES = \
../utils.c \
../writer.c
-test_ifcfg_rh_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -DTEST_IFCFG_DIR=\"$(abs_srcdir)\" \
- -DTEST_SCRATCH_DIR=\"$(abs_builddir)/\" \
- -DSYSCONFDIR=\"nonexistent\" \
- -DSBINDIR=\"nonexistent\"
-
test_ifcfg_rh_LDADD = \
$(top_builddir)/src/libNetworkManager.la