summaryrefslogtreecommitdiff
path: root/daemons/gptp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/gptp/CMakeLists.txt')
-rw-r--r--daemons/gptp/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/daemons/gptp/CMakeLists.txt b/daemons/gptp/CMakeLists.txt
index 4935e665..fb7d19b3 100644
--- a/daemons/gptp/CMakeLists.txt
+++ b/daemons/gptp/CMakeLists.txt
@@ -6,8 +6,16 @@ file(GLOB GPTP_COMMON "./common/*.cpp" "./common/*.c")
if(UNIX)
include_directories( include "./linux/src" )
- file(GLOB GPTP_OS "./linux/src/*.cpp")
- target_link_libraries(gptp pthread)
+ file(GLOB GPTP_OS
+ "./linux/src/daemon_cl.cpp"
+ "./linux/src/linux_ipc.cpp"
+ "./linux/src/platform.cpp"
+ "./linux/src/linux_hal_persist_file.cpp"
+ "./linux/src/linux_hal_generic.cpp"
+ "./linux/src/linux_hal_generic_adj.cpp"
+ "./linux/src/linux_hal_common.cpp")
+ add_executable (gptp ${GPTP_COMMON} ${GPTP_OS})
+ target_link_libraries(gptp pthread rt)
elseif(WIN32)
if( CMAKE_SIZEOF_VOID_P EQUAL 8 )
link_directories($ENV{WPCAP_DIR}/Lib/x64)