summaryrefslogtreecommitdiff
path: root/daemons/gptp/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/gptp/doc/CMakeLists.txt')
-rw-r--r--daemons/gptp/doc/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/daemons/gptp/doc/CMakeLists.txt b/daemons/gptp/doc/CMakeLists.txt
deleted file mode 100644
index c6fc3dcc..00000000
--- a/daemons/gptp/doc/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-
-# add a target to generate API documentation with Doxygen
-find_package(Doxygen)
-option(BUILD_DOCUMENTATION "Create and install the HTML based API documentation (requires Doxygen)" ${DOXYGEN_FOUND})
-
-if(BUILD_DOCUMENTATION)
- if(NOT DOXYGEN_FOUND)
- message(FATAL_ERROR "Doxygen is needed to build the documentation.")
- endif()
-
- set(doxyfile_in ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in)
- set(doxyfile ${CMAKE_CURRENT_SOURCE_DIR}/build/Doxyfile)
-
- configure_file(${doxyfile_in} ${doxyfile} @ONLY)
-
- add_custom_target(doc
- COMMAND ${DOXYGEN_EXECUTABLE} ${doxyfile}
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
- COMMENT "Generating API documentation with Doxygen"
- VERBATIM)
-
- #install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc)
-endif()