summaryrefslogtreecommitdiff
path: root/lib/avtp_pipeline/openavb_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/avtp_pipeline/openavb_common/CMakeLists.txt')
-rw-r--r--lib/avtp_pipeline/openavb_common/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/avtp_pipeline/openavb_common/CMakeLists.txt b/lib/avtp_pipeline/openavb_common/CMakeLists.txt
index e5f7d7f4..80dacfda 100644
--- a/lib/avtp_pipeline/openavb_common/CMakeLists.txt
+++ b/lib/avtp_pipeline/openavb_common/CMakeLists.txt
@@ -4,9 +4,16 @@ if (AVB_FEATURE_IGB)
${AVB_SRC_DIR}/../common/avb_igb.c
)
endif ()
+if (AVB_FEATURE_ATL)
+ message("-- common ATL library included")
+ SET (ATL_FILES
+ ${AVB_SRC_DIR}/../common/avb_atl.c
+ )
+endif ()
SET (SRC_FILES ${SRC_FILES}
${AVB_SRC_DIR}/../common/avb_gptp.c
${AVB_SRC_DIR}/openavb_common/mrp_client.c
${IGB_FILES}
+ ${ATL_FILES}
PARENT_SCOPE
)