summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2022-07-28 09:29:44 -0400
committerRay Strode <rstrode@redhat.com>2022-07-28 10:57:21 -0400
commitd25f48f44487d1ef14e46629d66faf8790698b65 (patch)
tree420b5fb9500ea5fec0480926c657076a55999bfa /tests/meson.build
parentca5cbab77b934ea899fbd230f7444231efe101d6 (diff)
downloadaccountsservice-d25f48f44487d1ef14e46629d66faf8790698b65.tar.gz
ci: Do a coding style check
Now that the accountsservice code has been uncrustified, it would be good to keep it that way going forward. plymouth has a script it runs during CI to check the coding style. This commit steals that script and uses it for accountsservice CI too.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index dedbe67..ff9004d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,3 +1,5 @@
+test('check-format', find_program('check-format.sh'))
+
libmocklibc = subproject('mocklibc').get_variable('libmocklibc')
envs = environment()