summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build50
1 files changed, 50 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..4987937
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,50 @@
+ifaces = files(
+ act_namespace + '.xml',
+ act_namespace + '.User.xml',
+)
+
+install_data(
+ ifaces,
+ install_dir: dbus_ifaces_dir,
+)
+
+install_data(
+ act_namespace + '.conf',
+ install_dir: dbus_conf_dir,
+)
+
+service_conf = configuration_data()
+service_conf.set('libexecdir', act_libexecdir)
+
+service = act_namespace + '.service'
+
+configure_file(
+ input: service + '.in',
+ output: service,
+ configuration: service_conf,
+ install: true,
+ install_dir: dbus_sys_dir,
+)
+
+policy = act_namespace.to_lower() + '.policy'
+
+i18n.merge_file(
+ policy,
+ input: policy + '.in',
+ output: policy,
+ po_dir: po_dir,
+ install: true,
+ install_dir: policy_dir,
+)
+
+if install_systemd_unit_dir
+ service = 'accounts-daemon.service'
+
+ configure_file(
+ input: service + '.in',
+ output: service,
+ configuration: service_conf,
+ install: true,
+ install_dir: systemd_system_unit_dir,
+ )
+endif