summaryrefslogtreecommitdiff
path: root/alsactl/Makefile.am
diff options
context:
space:
mode:
authorJaroslav Kysela <perex@perex.cz>2021-02-26 19:28:03 +0100
committerJaroslav Kysela <perex@perex.cz>2021-03-04 21:15:56 +0100
commit17b4129e6c89d1a96d4d86dabea38389927e3cf4 (patch)
treee15616fbd46efc27531f159a435b3c48c85f0154 /alsactl/Makefile.am
parentc1f8cc2f07d8e69db8f51d6af4563ed8a9ecf912 (diff)
downloadalsa-utils-17b4129e6c89d1a96d4d86dabea38389927e3cf4.tar.gz
alsactl: add 'clean' command to remove the application controls
It is handy to remove all card controls created by applications. This change allows to remove those controls for all cards, selected card or selected card with a control id filter list like: alsactl clean 0 "name='PCM'" "name='Mic Phantom'" Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'alsactl/Makefile.am')
-rw-r--r--alsactl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/alsactl/Makefile.am b/alsactl/Makefile.am
index c1031ac..deff2cd 100644
--- a/alsactl/Makefile.am
+++ b/alsactl/Makefile.am
@@ -10,7 +10,7 @@ EXTRA_DIST=alsactl.1 alsactl_init.xml
AM_CFLAGS = -D_GNU_SOURCE
alsactl_SOURCES=alsactl.c state.c lock.c utils.c init_parse.c init_ucm.c \
- daemon.c monitor.c
+ daemon.c monitor.c clean.c
alsactl_CFLAGS=$(AM_CFLAGS) -D__USE_GNU \
-DSYS_ASOUNDRC=\"$(ASOUND_STATE_DIR)/asound.state\" \