summaryrefslogtreecommitdiff
path: root/alsactl/Makefile.am
diff options
context:
space:
mode:
authorJaroslav Kysela <perex@perex.cz>2022-02-02 15:31:33 +0100
committerJaroslav Kysela <perex@perex.cz>2022-02-02 15:34:40 +0100
commit8403967669eaa9405a43d430b4ac7e5f0ea1b75e (patch)
tree82e43af59fdb6c65034f7b6f20d9cfc8f579ee2e /alsactl/Makefile.am
parent64fa37f09b29a7675246a36361e25fd218ab7852 (diff)
downloadalsa-utils-8403967669eaa9405a43d430b4ac7e5f0ea1b75e.tar.gz
alsactl: add locking for per-card initialization
Introduce the -K,--lock-dir parameter to specify the locking directory. If the locking is active, files card<NUM>.lock are used to serialize the multiple initialization requests (udev, service). Allow the relative -O,--lock-file argument (it's default now). Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'alsactl/Makefile.am')
-rw-r--r--alsactl/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/alsactl/Makefile.am b/alsactl/Makefile.am
index deff2cd..3d2f6e8 100644
--- a/alsactl/Makefile.am
+++ b/alsactl/Makefile.am
@@ -14,7 +14,8 @@ alsactl_SOURCES=alsactl.c state.c lock.c utils.c init_parse.c init_ucm.c \
alsactl_CFLAGS=$(AM_CFLAGS) -D__USE_GNU \
-DSYS_ASOUNDRC=\"$(ASOUND_STATE_DIR)/asound.state\" \
- -DSYS_LOCKFILE=\"$(ASOUND_LOCK_DIR)/asound.state.lock\" \
+ -DSYS_LOCKPATH=\"$(ASOUND_LOCK_DIR)\" \
+ -DSYS_LOCKFILE=\"asound.state.lock\" \
-DSYS_PIDFILE=\"$(ALSACTL_PIDFILE_DIR)/alsactl.pid\"
noinst_HEADERS=alsactl.h list.h init_sysdeps.c init_utils_string.c \