summaryrefslogtreecommitdiff
path: root/alsactl/Makefile.am
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2017-09-26 19:36:12 +0100
committerTakashi Iwai <tiwai@suse.de>2017-10-06 14:32:16 +0200
commitf72a296d23dd49e239ae8268498351953ef7bd94 (patch)
treecf1a07bbca2e824457639bbd92e27b0903bb66c2 /alsactl/Makefile.am
parentdbd4fc84f82bd28ec54cb1c494570dbc6e04302a (diff)
downloadalsa-utils-f72a296d23dd49e239ae8268498351953ef7bd94.tar.gz
alsactl: Move systemd unit start-up from basic.target to sound.target
Ensures soundcard is ready before restoring state. sound.target added to systemd in v18: https://cgit.freedesktop.org/systemd/systemd/commit/?id=88dfa2938af Simplify dependencies: - After=alsa-state.service is not needed because both units test for @daemonswitch@ with opposite outcomes. - After=sysinit.target is automatically added by systemd. First proposed by Tom Yan. Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Takashi Iwai <tiwai@suse.de>
Diffstat (limited to 'alsactl/Makefile.am')
-rw-r--r--alsactl/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/alsactl/Makefile.am b/alsactl/Makefile.am
index cac8094..90fab9d 100644
--- a/alsactl/Makefile.am
+++ b/alsactl/Makefile.am
@@ -29,8 +29,8 @@ systemdsystemunit_DATA = \
install-data-hook:
$(MKDIR_P) -m 0755 \
- $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants
- ( cd $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants && \
+ $(DESTDIR)$(systemdsystemunitdir)/sound.target.wants
+ ( cd $(DESTDIR)$(systemdsystemunitdir)/sound.target.wants && \
rm -f alsa-state.service alsa-restore.service && \
$(LN_S) ../alsa-state.service alsa-state.service && \
$(LN_S) ../alsa-restore.service alsa-restore.service)