summaryrefslogtreecommitdiff
path: root/alsaucm/Makefile.am
diff options
context:
space:
mode:
authorJaroslav Kysela <perex@perex.cz>2018-09-07 10:53:19 +0200
committerJaroslav Kysela <perex@perex.cz>2018-09-07 10:54:07 +0200
commit25bea6baf7097dc0a701b27587be88b0b54a529c (patch)
tree9d576392f9e290a5c333081cba8e4b032f45782a /alsaucm/Makefile.am
parentf6b59282f7c3bddc6aa4aca93e8e19163955675b (diff)
downloadalsa-utils-25bea6baf7097dc0a701b27587be88b0b54a529c.tar.gz
alsaucm: add alsa-ucm udev rules for PAZ00 (Toshiba AC100/Dynabook AZ).
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'alsaucm/Makefile.am')
-rw-r--r--alsaucm/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/alsaucm/Makefile.am b/alsaucm/Makefile.am
index ee0391e..651f678 100644
--- a/alsaucm/Makefile.am
+++ b/alsaucm/Makefile.am
@@ -15,4 +15,17 @@ alsaucm_LDADD = -lasound
%.1: %.rst
rst2man $< > $@
-EXTRA_DIST = alsaucm.rst
+udevrules_DATA = \
+ 89-alsa-ucm.rules
+
+edit = \
+ $(SED) -r -e 's,@bindir\@,$(bindir),g' \
+ -e 's,@mydatadir\@,$(mydatadir),g' \
+ < $< > $@ || rm $@
+
+89-alsa-ucm.rules: 89-alsa-ucm.rules.in
+ $(edit)
+
+EXTRA_DIST = alsaucm.rst 89-alsa-ucm.rules.in
+
+CLEANFILES = 89-alsa-ucm.rules